Bug #317 - Doesn't load or save a document
Product:PageStream (Windows)Reported By:T.J. Zweers
Severity:NormalAssigned To:Deron Kazmaier
Priority:Average sign in to watch (4 are watching)
Status:ReopenedReported:2011-03-19 02:56:46
Category:Text EditingUpdated:2011-03-19 02:56:46
Summary:Doesn't load or save a document
Keywords:not loading saving document
Attached Files:No files attached.
 Sign In to add a file.

PGS has, now and then (!), a problem which I can't put a finger on.

Then PGS cannot open a document, nor can it save a new made document (when there is text in it).

Loading: Unable to load document because IFF CTXT filter not found (and Abort to click away this requester).
Loading an empty (!) document does work.

Saving: Unable to load document because EPS filter not found, AND: Unable to load document because IFF ILBM filter not found (to click away this requester). (Now, this could be some wrong calls inside PGS: talking about 'loading' while saving, EPS or IFF ILBM)
I can save a new document, IF it is still empty. IF there is text, just any, it won't save.

Pictures only (no text in it), bitmaps, in this document? It is saved.
Ilus, when it has text in it, won't be load into this document: Unable to save document because IFF CTXT filter not found, AND: Unable to load document because IFF ILBM filter not found (to click away this requester). (Maybe some wrong calls inside PGS)

There is no crash report, because PGS doesn't crash.

I talk about PGS because older PGS versions CAN open and save documents on the same system where doesn't work. For instance does work.

The only way to make PGS work again, is to restart my computer.

Just answers to e-mails, I have made before, on this problem: I have no problems with my hard disk that I am aware of. And not loaded any large graphic before the problem.

T.J. Zweers wrote...2011-05-20 12:33:38

Additional information: before I let my computer sleep, I could edit a document. After I woke up the computer, PGS wouldn't open a document.
I did use Firefox, Thunderbird and notepad. Maybe this has nothing to do with the bug. Maybe restarting is the key to this bug, as is the normal start-up (boot) from the computer. Something is left out with start-ups (Windows), but what?

Of course PGS did work! What has, what doesn't have?

T.J. Zweers wrote...2011-06-05 07:39:37

A bad day for me and PGS, but Firefox and Thunderbird are off the hook.
Today I could not open any document.
Two restarts (not: quit Windows, wait a while than push the on-button) in a row: no document opens.
I started to stop some automatic start ups in Window with msconfig, like Corel, HP, Qnap, Winamp and Umax. Nothing helps.
Once I quit PGS, but couldn't start any PGS: 2 MB still in memory (task manager). After I killed that PGS opens again.

(Once - not this day - I could open a document, but PGS refuses to load TIF-files. Only completely restart my computer solved that)

Deron Kazmaier wrote...2011-06-05 14:52:06

Hmm. I don't see this as a load/save problem, but more likely some kind of random memory corruption. I'll keep looking for a possible explanation, but it may be specific to your configuration. Hopefully one of us will figure it out!

T.J. Zweers wrote...2011-06-07 15:13:48

If (!) it is a memory corruption, why does PGS work under the same circumstances (quit PGS, start PGS no problem at all)?

T.J. Zweers wrote...2012-02-07 07:48:42

Today again the load and save problem for (not the!).
With I can open a new document, place text on it and change the typeface/font. Of course it won't save.

Starting with a new document: this one will not save.

Steve Bradfield wrote...2012-02-27 19:43:25

I seem to be having a similar problem. I recently purchased Pro, and it won't load any of my PS4 docs, nor will it create a new document. I end up looking at an empty space where the page should be.

T.J. Zweers wrote...2012-04-10 14:45:23

I close this bug, because it doesn't exist for about a month:

I had those problems for about almost two years, since PGS came out: October 2010. The strange thing is/was, that PGS was still working, when PGS didn't.

I am (was) the only with this bug!

So what has changed?
It's still the same computer, the same main-board, the same second hard-disk.
The on-board graphics card was broken, so I got me a new graphic board. And I went from 2 to 4 GB RAM.
At about the same time my first hard-disk failed too. So, I have a SSD (Solid-state drive) as first disk (C:\\) now.

PGS is still at the same place on the second hard-disk, so the same configuration.
The repair shop put a new Windows Pro on it (so not the HP version).

So the bug was initialized by HP Windows 7? Probably. But what?
Or the small amount of RAM (first 2 MB)? Don't think so.
The old disk wasn't fast enough (SSD is fast!)? No, could be.
Was PGS the problem? No, not really, since it is exactly the same PGS. Only strange was that worked, when not. So everything pointed to

Oh, I remember another thing:
On the old configuration the computer went to sleep after not using it.
On the new configuration the computer never get to sleep.

For Steve: I think loading problems from PGS 4 into PGS is another kind of bug.
\n\n[Status updated to \'Works for Me\' on Tue, 10 Apr 2012 14:45:23 -0400]

Steve Bradfield wrote...2012-04-10 18:25:11

I don't think it is a problem with Windows 7. I still have XP (old computer) and it still won't work for me. It's not just a problem with loading PGS 4 documents - it won't begin a new document either. It doesn't do anything but sit there. If I click any other buttons it crashes.\n\n[Status updated to \'Reopened\' on Tue, 10 Apr 2012 18:25:11 -0400]

T.J. Zweers wrote...2012-04-12 14:48:43

I still think yours is a very different problem, Steve.
My former bug doesn't crash PGS any time. It simply doesn't open. Just a warning, and that is it.
Can you put PGS on your system? I can send you this privately, because saves PGS (and me) each time let me down.

You can also place your comments also on the forum: PageStreamSupport@yahoogroups.com

On more thing, just guessing: you have registered PGS (http://www.pagestream.org/?action=Documents&id=82)?

Steve Bradfield wrote...2012-04-12 16:22:40

I still have PGS 4 installed and it runs fine. PGS and it opens with no problem, do I'm sure will install and run, and I'd love to have it.

And yes, I registered so I'm all legal.

T.J. Zweers wrote...2012-04-12 17:18:11

You misunderstood me (why would you be onhttp://www.pagestream.org/ and can sign in to add a comment to the bug report).
No, what I mend that you (actually PGS) didn't are in the demo mode (I have no idea how PGS behaves, when the time has expired).
Also PGS 5 does things (registration) the other way than PGS 4. Even the early PGS 5 does behaves different than the latest.
PGS 5 (XP): C:\Documents and Settings\{username}\Application Data\PageStream5\
PGS 4: in the folder where you have the PageStream installed

Steve Bradfield wrote...2012-04-12 23:23:57

You're right, I'm not understanding. I did pay for my copy of PageStream 5, and it is properly registered as far as I can tell.

Robert V. Copper wrote...2012-05-04 23:05:31

I have found that certain windows updates cause almost every problem that I have with pagestream. It works fine windows does an automatic update and it develops problems with copy and paste and now this thing with no saving. When I roll back to a previous system restore it works again. I believe that we are running afoul of some security threat. I am now manually installing one update at a time and then running pagestream to see if it works. In short try a system restore go way back if it has been a while since pagestream worked for you

T.J. Zweers wrote...2012-05-05 02:41:36

Well Robert, it is likely that you found 'a problem maker'.
Only, the copy and paste behavior was once in a while: it works right for a long time, and then... it happens (and PGS did work then).
Good hunting though!

T.J. Zweers wrote...2012-05-05 02:45:30

I left out a big change (I didn't install Windows myself).

I use the 64 bit version of Windows 7!

(And I installed the 32 bit version of Windows 7 two years ago, just to be sure that PGS does works!)

Steve Bradfield wrote...2015-03-17 16:11:23

I'm back after two years with the same (or a similar) problem. I have a new computer running Windows 8.1. Everything has been fine for three months, but yesterday when I tried to load a document it went through the process, but there was nothing on the screen. A minute later PageStream crashed.

All my work for the past 20 years has been done on PageStream, and now I can't access any of it.

T.J. Zweers wrote...2015-03-17 18:25:53

Just delete PageStream5.ini (keep a copy, just te be sure).

Does this help?

Steve Bradfield wrote...2015-03-17 18:40:26

I found the proper folder (I think), but there is no 'AppData' folder. I found several 'Roaming' folders in different places, but they are all empty.

T.J. Zweers wrote...2015-03-17 18:50:56


User might be another name (yours?). I don't mean C:\Users, but the next one.

Steve Bradfield wrote...2015-03-17 18:57:21

I found the proper folder (I think), but there is no 'AppData' folder. I found several 'Roaming' folders in different places, but they are all empty.

Steve Bradfield wrote...2015-03-17 19:01:17

C:\Users\Steve has no AppData folder. It does have its own Roaming folder, but all that is in there is Intel\Wireless, and that is empty.

There is also a 'Public' folder under Users, but it has the same thing.

T.J. Zweers wrote...2015-03-17 19:03:11

Do a search for PageStream5.ini. I do not own Windwos 8, so maybe I can't help you there.

Steve Bradfield wrote...2015-03-17 19:03:17

C:\Users\Steve has no AppData folder. It does have its own Roaming folder, but all that is in there is Intel\Wireless, and that is empty.

There is also a 'Public' folder under Users, but it has the same thing.

Steve Bradfield wrote...2015-03-17 19:12:30

I'm doing a search as you suggested. I do appreciate your help.

Steve Bradfield wrote...2015-03-17 20:18:05

A complete system restore seems to have done the trick. Thanks again for going out of your way to help me.

T.J. Zweers wrote...2015-03-18 02:30:18

Anyway it is working again.
By the way: next time you better use PageStreamSupport@yahoogroups.com
Because the only ones listening here (bug report) are you, Deron, Robert, me and an occasional reader.
What stays is the time difference: your last mail was after one o'clock midnight (local time here).

Oh, one more tip: when PGS doesn't work (happens, like: copy / paste) I use PGS under the same circumstances (without rebooting)!

Steve Bradfield wrote...2015-03-18 12:34:19

Okay. From now on I'll use the Yahoo Groups site. I'm registered there, but for some reason I couldn't find it. Now I have the address.

One more question: How can I get

T.J. Zweers wrote...2015-03-18 15:33:22

Just send a mail to PageStreamSupport@yahoogroups.com, and I figure it out. ;)

Add a Comment
Sign in to add a comment.

Bug #317 - Doesn't load or save a document by T.J. Zweers   not loading saving document
  created:2011-03-19 02:56:46   last updated:2011-03-19 02:56:46
  Copyright © 1985-2024 GrasshopperLLC. All Rights Reserved.

sign in to add a bug