Bug #28 - Memory leak when undo table operation
Product:PageStream (All Platforms)Reported By:Tim Doty
Severity:CriticalAssigned To:Deron Kazmaier
Priority:Average sign in to watch (1 is watching)
Status:NewReported:2004-12-24 03:56:00
Category:Document/LayoutUpdated:2004-12-24 03:56:00
Summary:Memory leak when undo table operation
Attached Files:No files attached.
 Sign In to add a file.

Sometimes PgS goes into a runaway situation with memory allocation. I have seen this twice now with undo operations in a table. The first was somewhat more involved, but definitely occured after undoing a text operation. The second was much simpler:

1. Create new document
2. Draw table
3. Add four columns (total of eight)
4. Add a row (total of five)
5. Resize to page
6. With reshape tool select first cell
7. Change column width in edit palette to 14.4pt
8. Oops, I meant column height, hit ctrl-z

PgS allocates memory until killed

------- Additional Comment #1 From Tim Doty 2004-12-24 04:03 -------

Tried the same exact steps and it didn't undo and it didn't cause a memory leak. However, when I went to the edit menu it had "Undo Duplicate". Eh? No duplication had happened. I tried "Undo" from the menu and nothing seemed to happen. I ended up moving the table and there was one underneath. Refresh did not work properly, but there were definitely two objects.

So I still can't seem to get a complete bound on the behavior, but there is definitely something wrong with tables and

------- Additional Comment #2 From Tim Doty 2004-12-24 04:17 -------

Tried again with variation of edit cell height as intended. The problem occured with either the undo or a refresh (sorry, wasn't being careful). However, trying again did not succeed in reproducing. Still, it seems to be fairly often for undos of table edits.

Went back to check PgS and looked at menu and sure enough, Undo was "Undo Duplicate" -- but I hadn't done that and I'm sure I hadn't hit the key by accident. Besides, it wasn't nudged in position.

Deleted both tables and redrew.

1. Draw table (default is 4x4)
2. Add four columns
3. Add one row
4. Resize to page
5. Change to reshape tool
6. Edit first row hight to 14.4pt

I checked the edit and it was "Undo Set Cell". I then hit Ctrl-Z. Nothing happened and I thought, ah, the document window was unselected so I bet nothing happened. I selected the document window, but instead of hitting ctrl-z I then checked the edit menu and undo was "Undo Edit Object" and the other was "Redo Set Cell".

Back to the document window I discovered that there were now two tables. Display started having refresh trouble so I ended up deleting both tables via ctrl-a. Parts of tables were still displayed and refresh had no effect. Selecting the table tool, however, did refresh the display.

Argh! At least part of the problem resolved: the refresh issue with this is non-existant. Apparently I never got around to modifying v5 prefs for F5 to be refresh and instead it is duplicate in place.

That does not resolve the two observed memory leaks tonight, however. Still working on it.

Add a Comment
Sign in to add a comment.

Bug #28 - Memory leak when undo table operation by Tim Doty   undo,table
  created:2004-12-24 03:56:00   last updated:2004-12-24 03:56:00
  Copyright © 1985-2021 GrasshopperLLC. All Rights Reserved.

sign in to add a bug