Bug #49 - Paragraph attributes aren't
Product:PageStream 5.0.1.36 (All Platforms)Reported By:Tim Doty
Severity:NormalAssigned To:Deron Kazmaier
Priority:Average sign in to watch (1 is watching)
Status:NewReported:2005-02-03 01:52:00
Category:Text EditingUpdated:2005-02-03 01:52:00
Summary:Paragraph attributes aren't
Keywords:paragraph attributes,paragraph format,paragraph style,paragraph
Attached Files:No files attached.
 Sign In to add a file.

Current behavior:
Click somewhere in a paragraph and set a paragraph style or attributes and nothing happens. Paragraph attributes are only evaluated at the beginning of a paragraph. Inserts, moves and deletes cause style and attribute crud to accumulate, in some cases to the point where you get @P1:@P2:@P1 repeated. Or a paragraph attribute will cling to the end of a preceding paragraph.

Desired behavior:
When setting paragraph attributes they should be inserted at the beginning of the paragraph, regardless of where the text cursor is at, for any paragraph that has any of its text selected. Only the last paragraph attribute before the first text of the paragraph should remain.

In short, paragraph attributes should be inserted at the beginning of a paragraph and only the smallest applicable set of attributes/styles should remain.

I know this bug has been around forever, but long standing doesn't mean it isn't a bug.

Add a Comment
Sign in to add a comment.

Bug #49 - Paragraph attributes aren't by Tim Doty   paragraph attributes,paragraph format,paragraph style,paragraph
  created:2005-02-03 01:52:00   last updated:2005-02-03 01:52:00
  Copyright © 1985-2020 GrasshopperLLC. All Rights Reserved.


sign in to add a bug